Author Topic: Nightmare Creatures  (Read 828 times)

0 Members and 1 Guest are viewing this topic.

Offline Gent

  • PJ64 Dever
  • Sr. Member
  • *****
  • Posts: 464
  • Karma: +2/-0
  • SuperFly Deving Guy
    • Project64 Website
Nightmare Creatures
« on: September 09, 2011, 11:03:08 pm »
Nightmare Creatures

Known Issues (what is a 'known issue'?)
 
  • core
    • pausing issue: game sometimes seems to hang,  just press pause (F2 or PAUSE) on your keyboard *twice* to resume.
  • input
    • Rumble (Force Feedback) is broken. If you enable Rumble on the default Jabo Direct Input then the game will not respond or load only at 5 fps. Only use Mempak.


Frequently Asked Questions (have you read Common Q&A ?)
 
  • none
Well where to start really...

The "Sometimes" is far more frequent then that when it comes to the pauing issue to a point where you are pressing F2 atlantes 5 times on some levels and it get beyond a joke.

as for the Rumble it is a shame.

If you also use NRage then as soon as you get to a part that requires Rumble it has a awful slow down (stuttering around 5 fps) and at no point is there any actual Rumble. so is this input? or actually core?

See the pj quick save for pausing

Offline RadeonUser

  • PJ64 Dever
  • Full Member
  • *****
  • Posts: 231
  • Karma: +1/-0
  • SuperFly Deving Guy
Re: Nightmare Creatures
« Reply #1 on: September 10, 2011, 03:01:49 am »
The core issue is very odd.
I know there is a missing opcode in the recompiler and I will try to add it but I don't know if it will help the hanging.
It may be useful to try the Large Compile Buffer option as I see this game comes close to using the normal 20MB buffer the recompiler normally uses.

As for the rumble pak issue we do need more information on that.
With the exception of the pauses the game works well for me, rumble included.

Offline Gent

  • PJ64 Dever
  • Sr. Member
  • *****
  • Posts: 464
  • Karma: +2/-0
  • SuperFly Deving Guy
    • Project64 Website
Re: Nightmare Creatures
« Reply #2 on: September 10, 2011, 11:02:38 am »
I have tried every setting with this to try to understand what is wrong my end but sadly nothing is helping.

this is the settings in the rdb that is already uploaded here so we should all be on the same setting

Code: [Select]
[2857674D-CC4337DA-C:45]
Good Name=Nightmare Creatures (U)
Internal Name=NIGHTMARE CREATURES
RDRAM Size=4
Counter Factor=1
Save Type=First Save Type
CPU Type=Recompiler
Self-modifying code Method=Protected Memory
Use TLB=Yes
Linking=Global
Reg Cache=Yes
Use Large Buffer=Yes
Delay SI=Yes
Status=Issues (core)
SP Hack=No
Core Note=(see GameFAQ)
Plugin Note=
Clear Frame=0
Audio Signal=No

Anyone with a Rumble pad could you please try this as this is the only game i have found this far where this is a issue :| every other game has rumble no problem when i start enabled or change in game play..... This Game has no rumble for me on default plugin when i swap from mempak to rumble and as described above, and terriblel when starting up with rumble enabled. I do have rumble on NRage but again it is 5fps after the 1st hit i receive. very very odd this....

Update: Body Harvest is another one i seem to get this propblem? love to have some feedback on this it is all very  ~X(
« Last Edit: September 11, 2011, 06:29:09 pm by Gent »

Offline Gent

  • PJ64 Dever
  • Sr. Member
  • *****
  • Posts: 464
  • Karma: +2/-0
  • SuperFly Deving Guy
    • Project64 Website
Re: Nightmare Creatures
« Reply #3 on: September 11, 2011, 06:14:49 pm »
Trotterwatch, nekokabu, do you have a rumble pad and could you check this error for us?

I have this issue but Rad does not.

Be good to get both your side of it.

Thanks
« Last Edit: September 11, 2011, 07:39:43 pm by Gent »

Offline RadeonUser

  • PJ64 Dever
  • Full Member
  • *****
  • Posts: 231
  • Karma: +1/-0
  • SuperFly Deving Guy
Re: Nightmare Creatures
« Reply #4 on: September 12, 2011, 05:10:40 pm »
The rumble issue is confirmed to be a problem with buggy gamepad drivers.
I have come up with a hack to decrease the load on the drivers but I would prefer this be implemented in the controller plugin as it does not belong in the core.
All this hack does is stop sending "turn off rumble" commands after a certain amount so I do not foresee any issues.

Barring any problems and if it is not implemented in the controller plugin I will keep the hack in the core.