Author Topic: Loading GameFAQ From Pj Help (Resolved)  (Read 420 times)

0 Members and 1 Guest are viewing this topic.

Offline Gent

  • PJ64 Dever
  • Sr. Member
  • *****
  • Posts: 455
  • Karma: +2/-0
  • SuperFly Deving Guy
    • Project64 Website
Loading GameFAQ From Pj Help (Resolved)
« on: August 17, 2011, 12:17:56 PM »
We have the default index page resolved but for some reason there is a curious issue with the GameFAQ still and opening on its own to opening in PJ. This happens in Rads Project64_1.6.1.exe but seems to be fine with Project64_Debug.exe and Project64_Release.exe

When you open it normally (Not from PJ) the format is correct in the Introduction being open and viewable. (Open Icon)

When you opening it from PJ (Help Section) It does not have the Introduction part open but instead closed. (Closed icon)
« Last Edit: January 10, 2012, 09:44:42 PM by Gent »

Offline Gent

  • PJ64 Dever
  • Sr. Member
  • *****
  • Posts: 455
  • Karma: +2/-0
  • SuperFly Deving Guy
    • Project64 Website
Re: Loading GameFAQ From Pj Help
« Reply #1 on: August 19, 2011, 12:52:57 AM »
Update: this is now fixed by Rad:

Code: [Select]
        case ID_HELP_GAMEFAQ:
            {
                char path_buffer[_MAX_PATH], drive[_MAX_DRIVE] ,dir[_MAX_DIR];
                char fname[_MAX_FNAME],ext[_MAX_EXT], HelpFileName[_MAX_PATH], HelpFileName2[_MAX_PATH];

                GetModuleFileName(NULL,path_buffer,sizeof(path_buffer));
                _splitpath( path_buffer, drive, dir, fname, ext );
                   _makepath( HelpFileName, drive, dir, "PJgameFAQ", "chm" );
                strcpy(HelpFileName2, HelpFileName);

                if (HtmlHelp(hWnd, HelpFileName, HH_DISPLAY_TOPIC, 1) == NULL) {
                    ShellExecute(hWnd, "open", HelpFileName2, NULL, NULL, SW_SHOW);
                }
            }
            break;

Thanks Rad.