Author Topic: October 28 2018  (Read 782 times)

0 Members and 1 Guest are viewing this topic.

Offline RadeonUser

  • PJ64 Dever
  • Full Member
  • *****
  • Posts: 229
  • Karma: +1/-0
  • SuperFly Deving Guy
October 28 2018
« on: October 28, 2018, 04:45:19 PM »
Hey Gent,
The latest version I am working.I think I'm still sorting things out from the removal of the registry.
I think I will want a separate file for the active cheat tracking but we will see later.
I'm not too satisfied with the speed of the browser, it's taking a bit too long on the scanning and there isn't much cpu% wise going on when that's happening.
I still need to update the file compressor to the latest version...
The sorting is finally fixed (So it should sort based on three keys, I had a logic snafu that made it stop on the first one)
Bunch of other little fixes I ran into as well -- Still need to do the colors on rom info but any feedback is appreciated.

Offline RadeonUser

  • PJ64 Dever
  • Full Member
  • *****
  • Posts: 229
  • Karma: +1/-0
  • SuperFly Deving Guy
Re: October 28 2018
« Reply #1 on: October 28, 2018, 06:15:53 PM »
This is a test.
For the WYSWIG Editor.

One empty line above.


Two empty lines above.

Offline RadeonUser

  • PJ64 Dever
  • Full Member
  • *****
  • Posts: 229
  • Karma: +1/-0
  • SuperFly Deving Guy
Re: October 28 2018
« Reply #2 on: October 29, 2018, 12:54:26 PM »
Same as yesterday except Gent pointed out some issues with cheats not being disabled properly.

Offline RadeonUser

  • PJ64 Dever
  • Full Member
  • *****
  • Posts: 229
  • Karma: +1/-0
  • SuperFly Deving Guy
Re: October 28 2018
« Reply #3 on: November 05, 2018, 04:12:54 PM »
More fixes here and there.

The color option should now display on rom options.
Plugins will now be loaded properly.

I'm still creating a massive #define list to handle that so I don't make any additional copy/paste mistakes.

The last build always wrote out an =, even if the setting didn't call for it.

Mostly small issues that I didn't catch before, should work better now but not completely 100% as I'm still chasing things.

Gent: I think there's still issues with posting, it's robbing my newlines again.
« Last Edit: November 05, 2018, 04:14:32 PM by RadeonUser »

Offline Gent

  • PJ64 Dever
  • Sr. Member
  • *****
  • Posts: 461
  • Karma: +2/-0
  • SuperFly Deving Guy
    • Project64 Website
Re: October 28 2018
« Reply #4 on: November 25, 2018, 12:26:33 PM »
What is the latest build, there is one after this right?

Offline RadeonUser

  • PJ64 Dever
  • Full Member
  • *****
  • Posts: 229
  • Karma: +1/-0
  • SuperFly Deving Guy
Re: October 28 2018
« Reply #5 on: November 25, 2018, 01:52:07 PM »
The latest one is from Oct 28 and I don't think it crashes on my side but I can take a look.
How is it crashing?
Fresh install no files?
« Last Edit: November 25, 2018, 02:01:51 PM by RadeonUser »

Offline RadeonUser

  • PJ64 Dever
  • Full Member
  • *****
  • Posts: 229
  • Karma: +1/-0
  • SuperFly Deving Guy
Re: October 28 2018
« Reply #6 on: November 25, 2018, 02:25:21 PM »
This is to get us on the latest build.
I fixed the storing position of the window but haven't touched anything else.

Offline RadeonUser

  • PJ64 Dever
  • Full Member
  • *****
  • Posts: 229
  • Karma: +1/-0
  • SuperFly Deving Guy
Re: October 28 2018
« Reply #7 on: November 25, 2018, 02:55:53 PM »
Fixed that issue on End Emulation where it crashed after a couple or more runs.
The change I did to better support Ice's plugin was at fault.

I didn't see that I was closing the plugin too early.
Essentially emulation was still trying to happen with a closed plugin.

Offline RadeonUser

  • PJ64 Dever
  • Full Member
  • *****
  • Posts: 229
  • Karma: +1/-0
  • SuperFly Deving Guy
Re: October 28 2018
« Reply #8 on: November 25, 2018, 03:23:09 PM »
If at first you don't succeed use a bigger hammer.

This time I'm pausing emulation once I close that bugger so it shouldn't crash anymore...
I hope.
Sigh.