Author Topic: Project64 1.6.1 On Win2K VMWare (D3D)  (Read 408 times)

0 Members and 1 Guest are viewing this topic.

Offline Gent

  • PJ64 Dever
  • Sr. Member
  • *****
  • Posts: 445
  • Karma: +2/-0
  • SuperFly Deving Guy
    • Project64 Website
Project64 1.6.1 On Win2K VMWare (D3D)
« on: October 24, 2011, 06:07:08 PM »

I have tried 1.6.1 on Win2000 using the very latest version of VMWare that supports D3D.


The result is Project64_1.6.1.exe is not  a valid win32 application: Is this a Bug? i have downloaded it several time and still the same, yest works on Win7 with no such error.
Or has support for the OS been removed?


Please see image of error below

Offline RadeonUser

  • PJ64 Dever
  • Full Member
  • *****
  • Posts: 202
  • Karma: +1/-0
  • SuperFly Deving Guy
Re: Project64 1.6.1 On Win2K VMWare (D3D)
« Reply #1 on: October 24, 2011, 06:30:03 PM »
Your guess is as good as mine.

Offline azimer

  • Apollo64 Dever
  • Newbie
  • *****
  • Posts: 13
  • Karma: +0/-0
Re: Project64 1.6.1 On Win2K VMWare (D3D)
« Reply #2 on: October 24, 2011, 06:38:10 PM »
http://connect.microsoft.com/VisualStudio/feedback/details/567679/executables-created-with-vc-2010-do-not-run-on-windows-2000

http://connect.microsoft.com/VisualStudio/feedback/details/526821/executables-built-with-visual-c-2010-do-not-run-on-windows-xp-prior-to-sp2

It's a Visual C++ 2010 issue.  If we want compatibility prior to XP SP2, we need to downgrade to 2008.

Configuration Properties/General/Platform Toolset...  v100 = 2010  v90 = 2008
« Last Edit: October 24, 2011, 07:02:15 PM by azimer »

Offline Gent

  • PJ64 Dever
  • Sr. Member
  • *****
  • Posts: 445
  • Karma: +2/-0
  • SuperFly Deving Guy
    • Project64 Website
Re: Project64 1.6.1 On Win2K VMWare (D3D)
« Reply #3 on: October 25, 2011, 12:30:36 PM »
I have tried a VS 2008 Build sent me by Rad and i installed VB 6 on 2k now i get the following errors
« Last Edit: October 25, 2011, 12:36:14 PM by Gent »

Offline Gent

  • PJ64 Dever
  • Sr. Member
  • *****
  • Posts: 445
  • Karma: +2/-0
  • SuperFly Deving Guy
    • Project64 Website
Re: Project64 1.6.1 On Win2K VMWare (D3D)
« Reply #4 on: October 25, 2011, 12:47:36 PM »
ok after placing the d3d.dll and mscvr80.dll in the root folder i get the following errors




Offline Gent

  • PJ64 Dever
  • Sr. Member
  • *****
  • Posts: 445
  • Karma: +2/-0
  • SuperFly Deving Guy
    • Project64 Website
Re: Project64 1.6.1 On Win2K VMWare (D3D)
« Reply #5 on: October 25, 2011, 12:57:24 PM »
After removing Direct64, Azis latest 60 w2 and Jabo d3d9 (Duh) i just get the following error on going into Settings and on emulator close.




Offline Gent

  • PJ64 Dever
  • Sr. Member
  • *****
  • Posts: 445
  • Karma: +2/-0
  • SuperFly Deving Guy
    • Project64 Website
Re: Project64 1.6.1 On Win2K VMWare (D3D)
« Reply #6 on: October 25, 2011, 01:48:25 PM »
The system is win2000 SP4 and has DX9c installed




Offline nekokabu

  • PJ64 Dever
  • Jr. Member
  • *****
  • Posts: 94
  • Karma: +1/-0
« Last Edit: October 25, 2011, 02:37:08 PM by nekokabu »

Offline Gent

  • PJ64 Dever
  • Sr. Member
  • *****
  • Posts: 445
  • Karma: +2/-0
  • SuperFly Deving Guy
    • Project64 Website
Re: Project64 1.6.1 On Win2K VMWare (D3D)
« Reply #8 on: October 25, 2011, 03:26:15 PM »
Hi Neko :) I copied imagehlp.dll and dbghelp.dll to PJ64 folder and now i get the following error