PJ64 SP Dev

W.I.P Dev => Project 64 1.6.1 Dev => Alpha/Untested => Topic started by: RadeonUser on October 28, 2018, 04:45:19 PM

Title: October 28 2018
Post by: RadeonUser on October 28, 2018, 04:45:19 PM
Hey Gent,
The latest version I am working.I think I'm still sorting things out from the removal of the registry.
I think I will want a separate file for the active cheat tracking but we will see later.
I'm not too satisfied with the speed of the browser, it's taking a bit too long on the scanning and there isn't much cpu% wise going on when that's happening.
I still need to update the file compressor to the latest version...
The sorting is finally fixed (So it should sort based on three keys, I had a logic snafu that made it stop on the first one)
Bunch of other little fixes I ran into as well -- Still need to do the colors on rom info but any feedback is appreciated.
Title: Re: October 28 2018
Post by: RadeonUser on October 28, 2018, 06:15:53 PM
This is a test.
For the WYSWIG Editor.

One empty line above.


Two empty lines above.
Title: Re: October 28 2018
Post by: RadeonUser on October 29, 2018, 12:54:26 PM
Same as yesterday except Gent pointed out some issues with cheats not being disabled properly.
Title: Re: October 28 2018
Post by: RadeonUser on November 05, 2018, 04:12:54 PM
More fixes here and there.

The color option should now display on rom options.
Plugins will now be loaded properly.

I'm still creating a massive #define list to handle that so I don't make any additional copy/paste mistakes.

The last build always wrote out an =, even if the setting didn't call for it.

Mostly small issues that I didn't catch before, should work better now but not completely 100% as I'm still chasing things.

Gent: I think there's still issues with posting, it's robbing my newlines again.
Title: Re: October 28 2018
Post by: Gent on November 25, 2018, 12:26:33 PM
What is the latest build, there is one after this right?
Title: Re: October 28 2018
Post by: RadeonUser on November 25, 2018, 01:52:07 PM
The latest one is from Oct 28 and I don't think it crashes on my side but I can take a look.
How is it crashing?
Fresh install no files?
Title: Re: October 28 2018
Post by: RadeonUser on November 25, 2018, 02:25:21 PM
This is to get us on the latest build.
I fixed the storing position of the window but haven't touched anything else.
Title: Re: October 28 2018
Post by: RadeonUser on November 25, 2018, 02:55:53 PM
Fixed that issue on End Emulation where it crashed after a couple or more runs.
The change I did to better support Ice's plugin was at fault.

I didn't see that I was closing the plugin too early.
Essentially emulation was still trying to happen with a closed plugin.
Title: Re: October 28 2018
Post by: RadeonUser on November 25, 2018, 03:23:09 PM
If at first you don't succeed use a bigger hammer.

This time I'm pausing emulation once I close that bugger so it shouldn't crash anymore...
I hope.
Sigh.