Recent Posts

Pages: 1 ... 8 9 [10]
91
Project 64 1.6.1 Dev / Re: Dropping Registry Access
« Last post by RadeonUser on March 05, 2018, 06:56:52 am »
Ugh, it's still got problems.
I thought I had fixed them all  :'(

By the way Gent:
Transformers Beast Wars... when did it get playable?  :-S
Or has that slow note been wrong for a while?

-Edit-
See if you can get a reliable way to get that to error on writing settings.
It works fine for me at times then not at all...
92
Project 64 1.6.1 Dev / Re: Dropping Registry Access
« Last post by RadeonUser on March 05, 2018, 06:39:29 am »
Ugh.
Simply ugh.

Registry dropped for application settings (New file called Project64.apps in Config directory now stores these settings).

Gent pointed out someone found out what was causing Taz Express to not show the appropriate letters.
I must apologize on this but I closed the window on my phone and have lost the link so I cannot give appropriate credit.
Gent, please find that link/name of the person so we can appropriately thank that person for the research/work.
As suggested I will likely end up adding an option to disable these fixes (Ai Shogi 3's as well as Taz Express') for better hack support.

Cheats might work again, sorry about that Gent.
I'm sure you'll let me know!

It's still not at a place where I like but this should work until I get the time to simplify the code.

There's been several tweaks along the way but I've forgotten quite a bit of them...
Thankfully I added comments to my commits so I'll share what's on there! lol

Should work on XP again, that was just an access violation being thrown because I made assumptions.
The cache file (ROC) should always be created/updated after a rom scan. (This was an issue before)
There was an issue writing to files, that's been (hopefully) sorted by now... Let me know.
The last one I see was a fix to stop the application from scanning for roms when exiting.
93
Project64 Legacy Open Beta / Re: Known Issues
« Last post by RadeonUser on March 01, 2018, 02:25:17 am »
Just so everyone knows I am still working towards this and have actually made progress (I swear!).
Gent's got a special build I upload mornings when I get a chance but trust me when I say you don't want it.
It is horribly broken, he's whining about cheat support not being there (News to me! I haven't touched that I swear!), and it's still got issues with XP (I thought I had fixed them all but apparently not!).

Just posting this to make it clear I'm working on it, is all.
As soon as  I reach a semi-stable point I'll upload a new build.
Whether that's in zip form or just the exe I don't know...
94
icepi8's TR64 OGL Graphic Plugin / Elmo's Number Journey (U) [!]
« Last post by Gent on February 27, 2018, 09:11:17 am »
Elmo's Number Journey (U) [!] is the same on the level select screen also, again here seen on Jabo.
95
icepi8's TR64 OGL Graphic Plugin / Re: Elmo's Letter Adventure (U) [!]
« Last post by Gent on February 27, 2018, 01:28:34 am »
Another part in game is the same as level select. To show this isn't a TR64OGL Specific Issue, here it is with Jabo 1.6.1
96
icepi8's TR64 OGL Graphic Plugin / Elmo's Letter Adventure (U) [!]
« Last post by Gent on February 26, 2018, 07:15:45 pm »
Ice, Every Plug i have tried on this game shows The Levels Screen like this.

Also you have Some Jigsawing going on.

Can you look at this at some point please?

In game is looking real nice.
97
Project64 Legacy Open Beta / Re: Known Issues
« Last post by RadeonUser on February 25, 2018, 03:41:17 am »
Gent on the next build I want you to keep an eye out on something I could reproduce before but now I can't.
When toggling directory recursion I was getting a crash so I went in and 'fixed' it but now it doesn't happen whatsoever.
It turns out the 'fix' did nothing of the sort, that's the confusing part on my end.

So now I'm left with an issue I could reproduce before but now no longer can't when I recompiled the previous build.

-Edit-
I might have fixed that actually, I finally got around to making sure the cache file (roc now) is always created.
Yes that was discussed months ago and it was something I swore I would fix before the Open Beta was released...
Well I finally got around to it!
98
Project64 Legacy Open Beta / Re: Known Issues
« Last post by RadeonUser on February 25, 2018, 02:38:17 am »
Okay I've taken a look at it and I think I should be able to work around the issue.
It's simply shoddy code that I don't think was ever updated.
I'll try to push out the change to remove the registry and upload a build... if not tonight then tomorrow morning.
99
Project64 Legacy Open Beta / Re: Known Issues
« Last post by Gent on February 24, 2018, 03:00:13 pm »
Ice's fav ;) :P


100
Project64 Legacy Open Beta / Re: Known Issues
« Last post by RadeonUser on February 24, 2018, 12:47:01 am »
Well I did mention one of the updates could have kilt it and I'm almost positive it was the change I made in the file browsing...


I'll see if I can load up a virtual machine this weekend and see if I
can get it working again.


On a sadder note now that the slave driver is back y'all can expect some actual progress being made :'(
Pages: 1 ... 8 9 [10]