Recent Posts

Pages: [1] 2 3 ... 10
Alpha/Untested / Re: March 16 2018
« Last post by RadeonUser on March 16, 2018, 02:43:19 PM »
Okay I tried to fix this but ran out of time.

First, back up the Project64.apps file as this seems to mess it up.

Go to Rom Settings then Rom Note and throw something in there and hit OK.
Go back and remove that Rom Note.
Is that 100% bringing up that permission denied prompt?
Alpha/Untested / Re: March 15 2018
« Last post by Gent on March 16, 2018, 02:37:39 PM »
This one?

Alpha/Untested / Re: March 15 2018
« Last post by RadeonUser on March 16, 2018, 02:28:17 PM »
ok that now enabled Browser once again after deleting the file and re setting.

But there is now a strange error when selecting Ices 07.03.2018 plug and then loading at rom


Tried to recreate with Jabo and got nothing, changed back to Ice and nothing :|

Just to leave a note of history/etc/what have you, this is a message that means the file in questions is being written to but another bit of code is ALSO trying to write at the same time.
Since this isn't allowed it will throw that error you saw.
However, it's not a very descriptive error is it...
That's what the library gives me though.

(Gent? Why is it putting that I instead of the smiley? The one scratching it's face and then palms up shrug)
Ok here are the shots without Frame buffer disabled and not recording video
Plugins / OGL VS DX When Recoring Video
« Last post by Gent on March 16, 2018, 12:37:59 PM »
Ok although ive now found my major issues with Ice;s OGL plugin is down to using Frame buffer Enabled, when recording a Screen for video it has the same effect.

So i have made a Video showing this On TR64OGL In Desktop and Fullscreen and then the same with Jabo (DX)

See Below

Ok this isnt only Full screen as if you leave the demo running and it goes to the underground (Metro) station when they start to fire guns for example the hit is very noticeable.

Here are some pictures Rad ask for below of:

Project64 1.6 with TR64_ogl WS(ver0.10.02 2018-03-07)

Project64 1.6.1 Legacy with TR64_ogl WS(ver0.10.02 2018-03-07)

Project64 2.4 with TR64_ogl WS(ver0.10.02 2018-03-07)

Alpha/Untested / Alpha/Untested Section
« Last post by RadeonUser on March 16, 2018, 06:48:23 AM »
Just a heads up for anyone interested.
I asked Gent to add this section as a sort of nightly builds area for me to simply deposit builds and, in general, mention what I am currently working on.
It didn't make sense to me to be doing that on posts when I might jump from issue to issue and not have a stable build anymore.

The work I'm doing with settings for example has had a lot of issues crop up...
So I need to fix them all before another 'stable' beta is released.
You'll likely find some chaos in here as things won't make sense (I will start a new thread for every day of builds, possibly breaking continuity of threads/posts).

So it's really a kind of sandbox that any member can participate in and it will give me specific dates for people to mention possible problems.
Anyone can participate as far as I know, you'll likely just need to be logged in to download the attachments and to leave feedback.

Once a stable point is reached the build will be added to the Downloads section for anyone, even guests, to download.
Alpha/Untested / March 16 2018
« Last post by RadeonUser on March 16, 2018, 06:39:40 AM »
Managed to get a couple of tweaks in tonight (It's already the 16th! Yay! I need to get to bed)

I looked at TR64OGL full screen switching problem and I strongly suspect this is a failing on the plugin's switching back to windowed mode.
From what I can tell the plugin is told to switch to windowed mode and the plugin will restore the way the window looked before.
However, PJ64 also does this... or tries to.
There's a problem here with TR64OGL (From what I tested I could only get TR64OGL to behave like this) as I had to remove some of the times PJ64 attempts to restore the look of the window.

You'll also notice in previous builds the icon is missing when you go back to windowed mode.
I tried to fix that but only managed to get it working the first time you switch back to windowed mode from full screen.
Again, I could only see that in TR64OGL, all the other plugins I have (including some OpenGL) worked well.

The other issue I looked at was the frequency of saving the window position.
PJ64 used to do this on every move, I've changed it to only save that value on the application exiting.

I wanted to restore the speed to cheats as well but ran out of time.
I'm hoping this weekend will be a relaxed one so I can program some more.

So... basically.
TR64OGL won't go to a black screen that blocks seeing anything useful when doing fullscreen <-> window anymore, but I suspect TR64OGL is at fault here.
Less writes (So less cannot save settings prompts, hopefully...)
Also I'm adding my Windows experience index:

TR64_ogl WS(ver0.10.02 2018-03-07) has always been very resource hungry for my comp, and Ice has really been trying to lighten that load. With that said, it is still very much a painful issue for me of these specs:

OS:Windows 7 Professional 64Bit
CPU:Intel® Core™2 Quad Processor Q8400, 2.66 GHz, 1333 MHz FSB
System RAM:8GB Ddr2 Ram
Video:ATI Radeon HD 7470 PCI-E Graphics Card 1Gb
Sound:AMD High Definition Audio Device

My Driver Information:

Driver Packaging Version    15.20.1062.1004-150803a1-187669C
Catalyst Version    15.7.1
Provider    Advanced Micro Devices, Inc.
2D Driver Version
2D Driver File Path    /REGISTRY/MACHINE/SYSTEM/ControlSet001/Control/CLASS/{4D36E968-E325-11CE-BFC1-08002BE10318}/0001
Direct3D Version
OpenGL Version
Mantle Driver Version
Mantle API Version    Not Available
AMD Catalyst Control Center Version    2015.0804.21.41908

See Video Below

Also if anyone else on a Radeon Card can test this for me, it would really help.

You can find TR64_ogl WS(ver0.10.02 2018-03-07) build below.
Pages: [1] 2 3 ... 10